Android: čo s chybou „Non-upgradable APK“

Ak aktualizujte aplikáciu a stretnete sa s chybou „Non-upgradable APK„, respektíve:

You can’t rollout this release because it doesn’t allow any existing users to upgrade to the newly added APKs.

Tak chyba môže byť v tom, že „Version Code“ nového APK je nižšia ako „Version Code“ predošlého. V mojom prípade predošlé APK malo version code:

1209

a nové APK:

130

trvalo mi pár minút pokým som prišiel nato že práve toto znamená spomenutá chybová hláška.  Teda riešenie je, že nová „Version Code“ musí byť číselne viac ako „1209“, napríklad:

1300

a problém je vyriešený.

Be the first to comment

Leave a Reply

Your email address will not be published.


*